Jump to content

neilestrick

Moderators
  • Posts

    10,178
  • Joined

  • Last visited

About neilestrick

Contact Methods

  • Website URL
    http://www.neilestrickgallery.com

Profile Information

  • Location
     Grayslake, IL

Recent Profile Visitors

326,194 profile views

neilestrick's Achievements

Advanced Member

Advanced Member (3/3)

5.1k

Reputation

Single Status Update

See all updates by neilestrick

  1. my olympic kiln with bartlett controller was doing a slow bisque fire and seemed to have stopped heating at 1636.   18 hours after starting it, it is still at 1636 and has been for several hours now.  i have rather new elements in it. it is not  clicking like it is trying to heat to a higher temp as it does when it is heating.  any ideas i am not getting any error codes.

    1. neilestrick

      neilestrick

      It's odd that it hasn't given an error code yet, but sometimes they just don't. Go ahead and shut it off, though. if it hasn't gotten to temp yet, it's not going to. Here's what to check:

      1. Elements. They can just randomly fry out, so check for breaks, or better yet use a multi-meter to check for continuity.

      2. Connections. Check all wire connections in the control box to see if anything fried out.

      3. Thermocouple. If it's really worn and nasty looking it should be replaced. If everything else checks out, replace the thermocouple even if it looks good. Sometimes they can crack but it's not visible.

      4. Unload the kiln once it's cool, then do a custom program- 1 segment, rate of 9999, temp of 1000. Turn it on and it'll run full on. Let it go a few minutes then carefully crack the lid and see if any elements aren't glowing. If a single element is out, then there's probably a break in that element. If both elements in one section of the kiln aren't glowing, then the relay for that section is probably dead. In that case replace all the relays if they haven't been replaced recently. If you're handy with a multi-meter, you can check the power system that way and it's a little faster.

    2. augal

      augal

      thank you for the help i am about to go unload and see what i can find out. no error code had me worried.  it is an oloympic model S18HE and i tried looking up relays and thermocouples just to see what i might be looking at cost wise but cannot seem to find anywhere that will tell me which one i need.   neither have been replacedbefore.  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.