Jump to content
Wyatt

FTL Code on Paragon Kiln

Recommended Posts

Hi,

I have a Paragon TNF823. I changed out the elements and relays a few months back and have done less than a dozen firings since then. The wiring to the kiln is all correct and above specs. I recently completed a successful cone 6 firing with the kiln temperature reaching 2240. But now for two Cone 6 firings in a row the FTL(Firing Too Long) code has displayed and the kiln temperature stopped climbing in the 1730 to 1750 range. Does anyone have any advice or recommendations? Thank you. 

Share this post


Link to post
Share on other sites

Check your connections and the continuity of all elements. It is possible for a kiln to reach the 1700℉ range with one element out. But it won't go much past that. Perhaps the connector to one of the elements has come loose or there is some damage to one element. For a quick test of whether all elements are coming on, slip a scrap of paper behind every element, then turn it on to some program, doesn't matter what program, for 5 minutes. Then turn it off and check the paper scraps. Any that are charred are behind working elements, any that are not charred that element did not turn on. Troubleshoot from there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.