Jump to content

Search the Community

Showing results for tags 'kilnsitter'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ceramic Arts Daily Forums
    • Forum FAQ & Terms of Use
    • Studio Operations and Making Work
    • Clay and Glaze Chemistry
    • Equipment Use and Repair
    • Business, Marketing, and Accounting
    • Educational Approaches and Resources
    • Aesthetic Approaches and Philosophy
    • Int'l Ceramic Artists Network (ICAN) Operations and Benefits
    • Ceramic Events of Interest
    • Community Marketplace – Buy/Sell/Trade/Free

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hello! I was wondering if anyone could make a suggestion since last night I did a bisque fire at 04 cone. When I opened the kiln today the cone was completely straight, however it seemed the kiln did a full fire as I set the timer to 7 hours total and have never gone over that time span. I've used this method many times and have always gotten normal 90 degree bent cones so I was so taken back when the cone appeared as if no firing was done ? Could I of just gotten a defective cone ? I've used about 10 from the same pack with no issues. It's the strangest thing... I've never us
  2. Hello, I just came upon a medium size kiln. It was free, came with no manual or use instructions. I am a first time kiln user so I don't want to do anything without more information on this specific kiln. It is a very old Aim Ceramic Kiln with a sitter, Model K-10. Is there anyone out there who can give me some advice on this particular kiln? Thank you
  3. Hi all! I found a large old AIM Kiln at a thrift store for $50 , and it looks in good condition (pics attached). Based upon the badge specs of 230v 20amps, I had an electrician install a 240v outlet on a 30amp circuit. I fired it up and everything worked for a few minutes until it shut down, and wouldn't restart. After checking continuity through all the wiring, I decided to check voltage on the outlet. Sure enough it was out of whack. I called the electrician back and he confirmed that the circuit was fried. After connecting the kiln directly to the power drop at the circuit breake
  4. Took my kiln out of 17 year storage. Tried to fire to cone 04. Set timer to 10 hours and placed cone in kiln sitter and knob to " ceramics". It cut off at 10 hours but plate didn't drop on cone. I did have to replace the knob, as it was missing, yet it isn't quite the same as before and clicks for high fire, ceramics and overglaze are not where the wording is. I assumed the second click would be the " ceramics". What is your suggestions or knowledge on how to fix this issue with firing and/or should I buy the complete switch? Or would you think the switch is an issue? All coils are working.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.