Jump to content

Search the Community

Showing results for tags 'hobbytech 40'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ceramic Arts Daily Forums
    • Forum FAQ & Terms of Use
    • Studio Operations and Making Work
    • Clay and Glaze Chemistry
    • Equipment Use and Repair
    • Business, Marketing, and Accounting
    • Educational Approaches and Resources
    • Aesthetic Approaches and Philosophy
    • Int'l Ceramic Artists Network (ICAN) Operations and Benefits
    • Ceramic Events of Interest
    • Community Marketplace – Buy/Sell/Trade/Free

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello I have been using a Hobbytech 40 kiln for a few years, I think early 90s age but it could be older. The label has burnt off. I run it off a 13amp supply. The kiln isn’t in the best of condition. I am planning on buying a larger, more suitable kiln in the coming weeks but until then, I have to make do and mend. Over the last few months, the wires are burning out and firing is becoming tricky. I have to replace the wires ever 4-5 firings. The usual wire to go if the one at the top element connection. Anybody got any idea what would be causing this? I have removed and repacke
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.