Jump to content

Search the Community

Showing results for tags 'envirovent'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ceramic Arts Daily Forums
    • Forum FAQ & Terms of Use
    • Studio Operations and Making Work
    • Clay and Glaze Chemistry
    • Mold Making and Slip Casting
    • Equipment Use and Repair
    • Business, Marketing, and Accounting
    • Educational Approaches and Resources
    • Aesthetic Approaches and Philosophy
    • Int'l Ceramic Artists Network (ICAN) Operations and Benefits
    • Ceramic Events of Interest
    • Community Marketplace – Buy/Sell/Trade/Free
    • Job and Career Opportunities

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Just installed a new envirovent, seems to be working properly but it's really loud. Like vacuum cleaner loud. A freebie noise measuring app on my phone put it between 76-82 decibels, and I can't imagine this thing running for the length of a firing, for me and for neighbors. A few questions for the collective: Is noise a known issue for the envirovent II system, or is it possible I have a defective unit? If it is just the way it is, how do you handle the noise? Do you keep it running for the entire time? Has the noise discouraged you from using it? Thanks, all!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.