Jump to content

Search the Community

Showing results for tags 'element'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ceramic Arts Daily Forums
    • Forum FAQ & Terms of Use
    • Studio Operations and Making Work
    • Clay and Glaze Chemistry
    • Mold Making and Slip Casting
    • Equipment Use and Repair
    • Business, Marketing, and Accounting
    • Educational Approaches and Resources
    • Aesthetic Approaches and Philosophy
    • Int'l Ceramic Artists Network (ICAN) Operations and Benefits
    • Ceramic Events of Interest
    • Community Marketplace – Buy/Sell/Trade/Free
    • Job and Career Opportunities

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. I have a complete set of 12 new elements for a Duncan model 1029 kiln, 240V single phase. These were purchased from Euclid's Elements as backups, but we retired that kiln before they were needed. Asking $450, USPS priority shipping included.
  2. Hi! I have a (pretty old) second hand kiln that I tried to heat up today - just to test if the elements work - and, surprise surprise, absolutely nothing happened. As I say, the kiln seems pretty old and I expected it to struggle a little bit but to not even try to heat up... Does that mean there's probably a different issue other than the elements just being old and a bit worn out? Would even old elements do something? Any suggestions on where I could start with the troubleshooting? Thank you!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.