Jump to content

Search the Community

Showing results for tags 'Fireright'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ceramic Arts Daily Forums
    • Forum FAQ & Terms of Use
    • Studio Operations and Making Work
    • Clay and Glaze Chemistry
    • Equipment Use and Repair
    • Business, Marketing, and Accounting
    • Educational Approaches and Resources
    • Aesthetic Approaches and Philosophy
    • Int'l Ceramic Artists Network (ICAN) Operations and Benefits
    • Ceramic Events of Interest
    • Community Marketplace – Buy/Sell/Trade/Free

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. I just got back into making pottery after 10+ years. I have an Evenheat kiln with a kiln sitter and fireright heat switch. Yesterday I wanted to run a bisque cycle. We had to have a new 240 line run because we've moved since the last time I used the kiln. Power is getting to the dials because the kiln sitter light comes on but the Heat Switch seems off. When cycling back and forth between timer and heating it fades in instead of lighting up and there is no clicking sound indicating the elements coming on, and no heat. I've changed the heat setting and turned the heat switch off and just tried to get heat manually. I'm going to check to make sure the voltage is getting to the kiln but after that where should I begin looking?
  2. For some back story, I acquired an AIM kiln model #2327hc (never heard of them until I got this one) about 5 years ago from someone who had it in their basement. It's been in my basement since then until I just made space to hook it up. It hasn't been fired in at least 7 years so I had no idea if it would work. And it doesn't. I switch the kiln on and a red light comes on indicating power. I flip the other switch to "Run" and nothing happens. The kiln doesn't heat up, click, or the percentage lights and "HEAT" light doesn't come on. I have a Skutt kiln at my work that I've done work on, so I'm familiar with how the kiln should be sounding and responding. The interesting thing about this aim kiln is when I go to switch it off, for a spirit second inbetween moving the switch from on to off I hear the clicking sound that the relays make when pumping electricity into the elements. I'm pretty sure the wiring is fine, the kiln sitter is fine, I'm just not sure if the relay is the issue or if the circuit board in the Fireright is broken. It's an old kiln and things are dusty, but visually nothing looks broken. Based on some mis-matching screws I can tell someone did repairs on this before, but I honestly have no idea when the last time this was used. Does anybody else have an oldish aim kiln or a fireright jr controll box? Let me know if you've run into problems like this on other kilns even. Thanks! Pardon any misspellings, this is on my iPhone. -Ben
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.