Jump to content
kyartrat

Electric Kiln Firing for 48+ hours on high still not reaching temp

Recommended Posts

I'm using a 1227 skutt 1980 kiln with sitter..its always been quite slow to fire. But, this is a first.. it have been on high for 48 hours and still not reached temperature. First- is that safe for it to be on for so long? Second it is hitting cone 5 but not cone 6. Its very close. My cone is starting to bend but its just not there. -also all elements, relays, and wiring are 100%.

Is it ok to keep letting it run and hope it hits cone 6 in the next few hours or should i shut the kiln off since its been cone 5 for over 24 hours...? 

Edited by kyartrat

Share this post


Link to post
Share on other sites

As Neil recommends, shut it off, it's not going anywhere new tonight. Also reconsider your notion that everything is 100%. If I were going to place a bet on one single item, I would bet that your elements are long overdue for replacement. That they have electrical continuity does not mean they are producing the designed amount of heat. Get a multimeter if you don't already have one and measure the resistance of each section at each switch setting, and compare to the specifications in the Skutt document at

https://skutt.com/pdf/service_manual/11-5_ks_resistance.pdf

As noted in the technical reference, if your measured resistance is more than 1.5 ohms over the spec, that will explain why the kiln never got to temperature.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.