Jump to content
Sign in to follow this  
Benzine

Amaco 2 Speed Wheel, Now Only 1 Speed...

Recommended Posts

After getting the classroom studio set up for the year, I noticed, that one of my Amaco wheels did not run, at both speeds.  I took the control switch apart, and checked the connections and such.  But only one way would work.  I ordered a new switch, which didn't solve the problem.  So it doesn't seem to be a switch issue, but a motor issue.  

Any idea what the problem could be?  It worked at the end of last school year, and it was stored away safely for the Summer.

We can still use it, but obviously having both speeds would be ideal.

Share this post


Link to post
Share on other sites

Have you tried to contact AMACO? I doubt they would have a fix, but they might be able to point you in the right direction.

They had the tire for the cone drive on my old model B Amaco wheel and their people are very helpful.

Good luck and let us know how things work out.

Graybeard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×