Jump to content

loulou104

Members
  • Content Count

    2
  • Joined

  • Last visited

About loulou104

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. loulou104

    Rotarry switches?

    Sending you an email!
  2. loulou104

    Rotarry switches?

    ok, here goes. I replaced all elements in my paragon A88b kiln in December. Bisque fired cone 04 (bright red, orange, yellow) everything fine two weeks ago. Tried to do a glaze fire and never got past dark red. #2 and # 3 elements are not working. used volt meter and no power to them, checked not broken, checked connections. When i turn the two switches on to low and medium NO sound and no voltage. When i turn them to high i get the normal buzzing sound and #1 and #4 elements get hot....??? #1 and #2 elements are connected to the top switch and #3 and #4 are connected to the bottom switch. Rotary switches need replaced?????
  3. ok, here goes. I replaced all elements in my paragon A88b kiln in December. Bisque fired cone 04 (bright red, orange, yellow) everything fine two weeks ago. Tried to do a glaze fire and never got past dark red. #2 and # 3 elements are not working. used volt meter and no power to them, checked not broken, checked connections. When i turn the two switches on to low and medium NO sound and no voltage. When i turn them to high i get the normal buzzing sound and #1 and #4 elements get hot....??? #1 and #2 elements are connected to the top switch and #3 and #4 are connected to the bottom switch. Rotary switches need replaced?????

    1. Min

      Min

      Hi loulou, I would suggest posting your question in the Equipment Use and Repair section, you will likely get more replies there than here. This section is for more along the lines of what people are up to. Welcome to the forum.

×

Important Information

By using this site, you agree to our Terms of Use.